linux-input.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
* [PATCH v1] HID: ft260: fix i2c probing for hwmon devices
@ 2021-10-23 19:39 Michael Zaidman
  2021-11-19 14:46 ` Jiri Kosina
  0 siblings, 1 reply; 2+ messages in thread
From: Michael Zaidman @ 2021-10-23 19:39 UTC (permalink / raw)
  To: jikos
  Cc: benjamin.tissoires, aaron.jones, linux-kernel, linux-input,
	linux-i2c, Michael Zaidman, Germain Hebert

The below scenario causes the kernel NULL pointer dereference failure:
1. sudo insmod hid-ft260.ko
2. sudo modprobe lm75
3. unplug USB hid-ft260
4. plug USB hid-ft260

[  +0.000006] Call Trace:
[  +0.000004]  __i2c_smbus_xfer.part.0+0xd1/0x310
[  +0.000007]  ? ft260_smbus_write+0x140/0x140 [hid_ft260]
[  +0.000005]  __i2c_smbus_xfer+0x2b/0x80
[  +0.000004]  i2c_smbus_xfer+0x61/0xf0
[  +0.000005]  i2c_default_probe+0xf9/0x130
[  +0.000004]  i2c_detect_address+0x84/0x160
[  +0.000004]  ? kmem_cache_alloc_trace+0xf6/0x200
[  +0.000009]  ? i2c_detect.isra.0+0x69/0x130
[  +0.000005]  i2c_detect.isra.0+0xbf/0x130
[  +0.000004]  ? __process_new_driver+0x30/0x30
[  +0.000004]  __process_new_adapter+0x18/0x20
[  +0.000004]  bus_for_each_drv+0x84/0xd0
[  +0.000003]  i2c_register_adapter+0x1e4/0x400
[  +0.000005]  i2c_add_adapter+0x5c/0x80
[  +0.000004]  ft260_probe.cold+0x222/0x2e2 [hid_ft260]
[  +0.000006]  hid_device_probe+0x10e/0x170 [hid]
[  +0.000009]  really_probe+0xff/0x460
[  +0.000004]  driver_probe_device+0xe9/0x160
[  +0.000003]  __device_attach_driver+0x71/0xd0
[  +0.000004]  ? driver_allows_async_probing+0x50/0x50
[  +0.000004]  bus_for_each_drv+0x84/0xd0
[  +0.000002]  __device_attach+0xde/0x1e0
[  +0.000004]  device_initial_probe+0x13/0x20
[  +0.000004]  bus_probe_device+0x8f/0xa0
[  +0.000003]  device_add+0x333/0x5f0

It happened when i2c core probed for the devices associated with the lm75
driver by invoking 2c_detect()-->..-->ft260_smbus_write() from within the
ft260_probe before setting the adapter data with i2c_set_adapdata().

Moving the i2c_set_adapdata() before i2c_add_adapter() fixed the failure.

Signed-off-by: Michael Zaidman <michael.zaidman@gmail.com>
Signed-off-by: Germain Hebert <germain.hebert@ca.abb.com>
---
 drivers/hid/hid-ft260.c | 11 +++++------
 1 file changed, 5 insertions(+), 6 deletions(-)

diff --git a/drivers/hid/hid-ft260.c b/drivers/hid/hid-ft260.c
index 4ef1c3b8094e..8ee77f4afe9f 100644
--- a/drivers/hid/hid-ft260.c
+++ b/drivers/hid/hid-ft260.c
@@ -966,24 +966,23 @@ static int ft260_probe(struct hid_device *hdev, const struct hid_device_id *id)
 	mutex_init(&dev->lock);
 	init_completion(&dev->wait);
 
+	ret = ft260_xfer_status(dev);
+	if (ret)
+		ft260_i2c_reset(hdev);
+
+	i2c_set_adapdata(&dev->adap, dev);
 	ret = i2c_add_adapter(&dev->adap);
 	if (ret) {
 		hid_err(hdev, "failed to add i2c adapter\n");
 		goto err_hid_close;
 	}
 
-	i2c_set_adapdata(&dev->adap, dev);
-
 	ret = sysfs_create_group(&hdev->dev.kobj, &ft260_attr_group);
 	if (ret < 0) {
 		hid_err(hdev, "failed to create sysfs attrs\n");
 		goto err_i2c_free;
 	}
 
-	ret = ft260_xfer_status(dev);
-	if (ret)
-		ft260_i2c_reset(hdev);
-
 	return 0;
 
 err_i2c_free:
-- 
2.25.1


^ permalink raw reply	[flat|nested] 2+ messages in thread

* Re: [PATCH v1] HID: ft260: fix i2c probing for hwmon devices
  2021-10-23 19:39 [PATCH v1] HID: ft260: fix i2c probing for hwmon devices Michael Zaidman
@ 2021-11-19 14:46 ` Jiri Kosina
  0 siblings, 0 replies; 2+ messages in thread
From: Jiri Kosina @ 2021-11-19 14:46 UTC (permalink / raw)
  To: Michael Zaidman
  Cc: benjamin.tissoires, aaron.jones, linux-kernel, linux-input,
	linux-i2c, Germain Hebert

On Sat, 23 Oct 2021, Michael Zaidman wrote:

> The below scenario causes the kernel NULL pointer dereference failure:
> 1. sudo insmod hid-ft260.ko
> 2. sudo modprobe lm75
> 3. unplug USB hid-ft260
> 4. plug USB hid-ft260
> 
> [  +0.000006] Call Trace:
> [  +0.000004]  __i2c_smbus_xfer.part.0+0xd1/0x310
> [  +0.000007]  ? ft260_smbus_write+0x140/0x140 [hid_ft260]
> [  +0.000005]  __i2c_smbus_xfer+0x2b/0x80
> [  +0.000004]  i2c_smbus_xfer+0x61/0xf0
> [  +0.000005]  i2c_default_probe+0xf9/0x130
> [  +0.000004]  i2c_detect_address+0x84/0x160
> [  +0.000004]  ? kmem_cache_alloc_trace+0xf6/0x200
> [  +0.000009]  ? i2c_detect.isra.0+0x69/0x130
> [  +0.000005]  i2c_detect.isra.0+0xbf/0x130
> [  +0.000004]  ? __process_new_driver+0x30/0x30
> [  +0.000004]  __process_new_adapter+0x18/0x20
> [  +0.000004]  bus_for_each_drv+0x84/0xd0
> [  +0.000003]  i2c_register_adapter+0x1e4/0x400
> [  +0.000005]  i2c_add_adapter+0x5c/0x80
> [  +0.000004]  ft260_probe.cold+0x222/0x2e2 [hid_ft260]
> [  +0.000006]  hid_device_probe+0x10e/0x170 [hid]
> [  +0.000009]  really_probe+0xff/0x460
> [  +0.000004]  driver_probe_device+0xe9/0x160
> [  +0.000003]  __device_attach_driver+0x71/0xd0
> [  +0.000004]  ? driver_allows_async_probing+0x50/0x50
> [  +0.000004]  bus_for_each_drv+0x84/0xd0
> [  +0.000002]  __device_attach+0xde/0x1e0
> [  +0.000004]  device_initial_probe+0x13/0x20
> [  +0.000004]  bus_probe_device+0x8f/0xa0
> [  +0.000003]  device_add+0x333/0x5f0
> 
> It happened when i2c core probed for the devices associated with the lm75
> driver by invoking 2c_detect()-->..-->ft260_smbus_write() from within the
> ft260_probe before setting the adapter data with i2c_set_adapdata().
> 
> Moving the i2c_set_adapdata() before i2c_add_adapter() fixed the failure.
> 
> Signed-off-by: Michael Zaidman <michael.zaidman@gmail.com>
> Signed-off-by: Germain Hebert <germain.hebert@ca.abb.com>

Applied, thanks.

-- 
Jiri Kosina
SUSE Labs


^ permalink raw reply	[flat|nested] 2+ messages in thread

end of thread, other threads:[~2021-11-19 14:46 UTC | newest]

Thread overview: 2+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2021-10-23 19:39 [PATCH v1] HID: ft260: fix i2c probing for hwmon devices Michael Zaidman
2021-11-19 14:46 ` Jiri Kosina

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).