linux-bluetooth.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
* [Bug 213829] Intel AX210 Bluetooth controller doesn't start from warm boot
       [not found] <bug-213829-62941@https.bugzilla.kernel.org/>
@ 2021-09-10  4:41 ` bugzilla-daemon
  2021-10-17 18:05 ` bugzilla-daemon
                   ` (11 subsequent siblings)
  12 siblings, 0 replies; 13+ messages in thread
From: bugzilla-daemon @ 2021-09-10  4:41 UTC (permalink / raw)
  To: linux-bluetooth

https://bugzilla.kernel.org/show_bug.cgi?id=213829

Ron M (ron@cloudswarm.net) changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
                 CC|                            |ron@cloudswarm.net

--- Comment #4 from Ron M (ron@cloudswarm.net) ---
I have verified this issue is still present in 5.14.0 (and not present in
5.12.19)

-- 
You may reply to this email to add a comment.

You are receiving this mail because:
You are the assignee for the bug.

^ permalink raw reply	[flat|nested] 13+ messages in thread

* [Bug 213829] Intel AX210 Bluetooth controller doesn't start from warm boot
       [not found] <bug-213829-62941@https.bugzilla.kernel.org/>
  2021-09-10  4:41 ` [Bug 213829] Intel AX210 Bluetooth controller doesn't start from warm boot bugzilla-daemon
@ 2021-10-17 18:05 ` bugzilla-daemon
  2021-11-02 13:57 ` bugzilla-daemon
                   ` (10 subsequent siblings)
  12 siblings, 0 replies; 13+ messages in thread
From: bugzilla-daemon @ 2021-10-17 18:05 UTC (permalink / raw)
  To: linux-bluetooth

https://bugzilla.kernel.org/show_bug.cgi?id=213829

--- Comment #13 from Guillaume Binet (gbin@gootz.net) ---
I continued to investigate. The major difference between a cold boot and a warm
boot is the driver trying to load a firmware.

For the science, I just disabled this behavior and it looks like the device and
driver recover on a warm boot. Consider this a workaround and not a fix but at
least it works for me, bluetooth is available on a warm boot.

```
pal ➜  linux-5.14.12  diff -u drivers/bluetooth/btintel.c.old
drivers/bluetooth/btintel.c 
--- drivers/bluetooth/btintel.c.old     2021-10-17 13:56:23.583338189 -0400
+++ drivers/bluetooth/btintel.c 2021-10-17 14:01:16.113344330 -0400
@@ -1034,17 +1034,6 @@
                /* Skip reading firmware file version in bootloader mode */
                if (ver->fw_variant == 0x06)
                        break;
-
-               /* Skip download if firmware has the same version */
-               if (btintel_firmware_version(hdev, ver->fw_build_num,
-                                            ver->fw_build_ww,
ver->fw_build_yy,
-                                            fw, boot_param)) {
-                       bt_dev_info(hdev, "Firmware already loaded");
-                       /* Return -EALREADY to indicate that the firmware has
-                        * already been loaded.
-                        */
-                       return -EALREADY;
-               }
        }

        /* The firmware variant determines if the device is in bootloader
@@ -1074,21 +1063,6 @@
        int err;
        u32 css_header_ver;

-       /* Skip reading firmware file version in bootloader mode */
-       if (ver->img_type != 0x01) {
-               /* Skip download if firmware has the same version */
-               if (btintel_firmware_version(hdev, ver->min_fw_build_nn,
-                                            ver->min_fw_build_cw,
-                                            ver->min_fw_build_yy,
-                                            fw, boot_param)) {
-                       bt_dev_info(hdev, "Firmware already loaded");
-                       /* Return -EALREADY to indicate that firmware has
-                        * already been loaded.
-                        */
-                       return -EALREADY;
-               }
-       }
-
        /* The firmware variant determines if the device is in bootloader
         * mode or is running operational firmware. The value 0x01 identifies
         * the bootloader and the value 0x03 identifies the operational
```

-- 
You may reply to this email to add a comment.

You are receiving this mail because:
You are the assignee for the bug.

^ permalink raw reply	[flat|nested] 13+ messages in thread

* [Bug 213829] Intel AX210 Bluetooth controller doesn't start from warm boot
       [not found] <bug-213829-62941@https.bugzilla.kernel.org/>
  2021-09-10  4:41 ` [Bug 213829] Intel AX210 Bluetooth controller doesn't start from warm boot bugzilla-daemon
  2021-10-17 18:05 ` bugzilla-daemon
@ 2021-11-02 13:57 ` bugzilla-daemon
  2021-11-02 20:02 ` bugzilla-daemon
                   ` (9 subsequent siblings)
  12 siblings, 0 replies; 13+ messages in thread
From: bugzilla-daemon @ 2021-11-02 13:57 UTC (permalink / raw)
  To: linux-bluetooth

https://bugzilla.kernel.org/show_bug.cgi?id=213829

--- Comment #16 from Marco (rodomar705@protonmail.com) ---
After updating to 5.14.15, it got even worse, now it will literally drop the
connection with my mouse after 10 seconds and it will stop responding to any
command until a complete shutdown, all I get in the logs is a command timeout,
it will literally stop responding to my host.

[  358.869054] Bluetooth: hci0: command 0x0804 tx timeout
[  361.045200] Bluetooth: hci0: command 0x041f tx timeout
[  363.093133] Bluetooth: hci0: command 0x0406 tx timeout

[ 1436.437038] Bluetooth: hci0: command 0x0c03 tx timeout
[ 1444.437291] Bluetooth: hci0: HCI reset during shutdown failed

This even after a cold start.

Anyone with the same problem here?

-- 
You may reply to this email to add a comment.

You are receiving this mail because:
You are the assignee for the bug.

^ permalink raw reply	[flat|nested] 13+ messages in thread

* [Bug 213829] Intel AX210 Bluetooth controller doesn't start from warm boot
       [not found] <bug-213829-62941@https.bugzilla.kernel.org/>
                   ` (2 preceding siblings ...)
  2021-11-02 13:57 ` bugzilla-daemon
@ 2021-11-02 20:02 ` bugzilla-daemon
  2021-11-11  1:11 ` bugzilla-daemon
                   ` (8 subsequent siblings)
  12 siblings, 0 replies; 13+ messages in thread
From: bugzilla-daemon @ 2021-11-02 20:02 UTC (permalink / raw)
  To: linux-bluetooth

https://bugzilla.kernel.org/show_bug.cgi?id=213829

--- Comment #17 from Marco (rodomar705@protonmail.com) ---
(In reply to Marco from comment #16)
> After updating to 5.14.15, it got even worse, now it will literally drop the
> connection with my mouse after 10 seconds and it will stop responding to any
> command until a complete shutdown, all I get in the logs is a command
> timeout, it will literally stop responding to my host.
> 
> [  358.869054] Bluetooth: hci0: command 0x0804 tx timeout
> [  361.045200] Bluetooth: hci0: command 0x041f tx timeout
> [  363.093133] Bluetooth: hci0: command 0x0406 tx timeout
> 
> [ 1436.437038] Bluetooth: hci0: command 0x0c03 tx timeout
> [ 1444.437291] Bluetooth: hci0: HCI reset during shutdown failed
> 
> This even after a cold start.
> 
> Anyone with the same problem here?

This was fixed after a reinstall of linux-firmware, sorry, the problem after a
reboot is still there, though.

-- 
You may reply to this email to add a comment.

You are receiving this mail because:
You are the assignee for the bug.

^ permalink raw reply	[flat|nested] 13+ messages in thread

* [Bug 213829] Intel AX210 Bluetooth controller doesn't start from warm boot
       [not found] <bug-213829-62941@https.bugzilla.kernel.org/>
                   ` (3 preceding siblings ...)
  2021-11-02 20:02 ` bugzilla-daemon
@ 2021-11-11  1:11 ` bugzilla-daemon
  2021-11-11  3:12 ` bugzilla-daemon
                   ` (7 subsequent siblings)
  12 siblings, 0 replies; 13+ messages in thread
From: bugzilla-daemon @ 2021-11-11  1:11 UTC (permalink / raw)
  To: linux-bluetooth

https://bugzilla.kernel.org/show_bug.cgi?id=213829

Tedd An (tedd.an@intel.com) changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
                 CC|                            |tedd.an@intel.com

--- Comment #19 from Tedd An (tedd.an@intel.com) ---
This should be fixed with
https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/drivers/bluetooth/btintel.c?id=35191a0fe986bacf69bd842de81119dca7970f11

I tried it with 5.15 and didn't see the problem.

-- 
You may reply to this email to add a comment.

You are receiving this mail because:
You are the assignee for the bug.

^ permalink raw reply	[flat|nested] 13+ messages in thread

* [Bug 213829] Intel AX210 Bluetooth controller doesn't start from warm boot
       [not found] <bug-213829-62941@https.bugzilla.kernel.org/>
                   ` (4 preceding siblings ...)
  2021-11-11  1:11 ` bugzilla-daemon
@ 2021-11-11  3:12 ` bugzilla-daemon
  2021-11-13  3:43 ` bugzilla-daemon
                   ` (6 subsequent siblings)
  12 siblings, 0 replies; 13+ messages in thread
From: bugzilla-daemon @ 2021-11-11  3:12 UTC (permalink / raw)
  To: linux-bluetooth

https://bugzilla.kernel.org/show_bug.cgi?id=213829

--- Comment #20 from Guillaume Binet (gbin@gootz.net) ---
(In reply to Tedd An from comment #19)
> This should be fixed with
> https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/
> drivers/bluetooth/btintel.c?id=35191a0fe986bacf69bd842de81119dca7970f11
> 
> I tried it with 5.15 and didn't see the problem.

Sorry it is not.

Testing with the framework laptop on 
testing/linux 5.15.1.arch1-2

Steps to reproduce: 1. go to the bios and save settings, it starts bt
correctly. 2. Just reboot with for example the reboot command or come out of
hibernation etc... it fails as usual.

-- 
You may reply to this email to add a comment.

You are receiving this mail because:
You are the assignee for the bug.

^ permalink raw reply	[flat|nested] 13+ messages in thread

* [Bug 213829] Intel AX210 Bluetooth controller doesn't start from warm boot
       [not found] <bug-213829-62941@https.bugzilla.kernel.org/>
                   ` (5 preceding siblings ...)
  2021-11-11  3:12 ` bugzilla-daemon
@ 2021-11-13  3:43 ` bugzilla-daemon
  2021-11-13  9:19 ` bugzilla-daemon
                   ` (5 subsequent siblings)
  12 siblings, 0 replies; 13+ messages in thread
From: bugzilla-daemon @ 2021-11-13  3:43 UTC (permalink / raw)
  To: linux-bluetooth

https://bugzilla.kernel.org/show_bug.cgi?id=213829

--- Comment #24 from Josh Ellithorpe (quest@mac.com) ---
(In reply to Tedd An from comment #23)
> Could you try with the latest firmware from linux-firmware.git?
> https://git.kernel.org/pub/scm/linux/kernel/git/firmware/linux-firmware.git
> 
> Copy the intel/*.sfi to /lib/firmware/intel/ and cold boot.
> 
> It will help to rule out if it is fw issue or not.

I just tried. I installed the latest linux-firmware-git package that pulled
latest.

On cold boot I had `bluetoothctl list` hang after boot. Then after restarting
the bluetooth service, it showed the device but still refused to even do a
basic scan.

`Failed to start discovery: org.bluez.Error.NotReady`

Then after doing another quick cold boot (stayed off only a few seconds), no
device was listed at all. =\

-- 
You may reply to this email to add a comment.

You are receiving this mail because:
You are the assignee for the bug.

^ permalink raw reply	[flat|nested] 13+ messages in thread

* [Bug 213829] Intel AX210 Bluetooth controller doesn't start from warm boot
       [not found] <bug-213829-62941@https.bugzilla.kernel.org/>
                   ` (6 preceding siblings ...)
  2021-11-13  3:43 ` bugzilla-daemon
@ 2021-11-13  9:19 ` bugzilla-daemon
  2021-11-13 17:55 ` bugzilla-daemon
                   ` (4 subsequent siblings)
  12 siblings, 0 replies; 13+ messages in thread
From: bugzilla-daemon @ 2021-11-13  9:19 UTC (permalink / raw)
  To: linux-bluetooth

https://bugzilla.kernel.org/show_bug.cgi?id=213829

--- Comment #25 from Marco (rodomar705@protonmail.com) ---
(In reply to Josh Ellithorpe from comment #24)
> (In reply to Tedd An from comment #23)
> > Could you try with the latest firmware from linux-firmware.git?
> > https://git.kernel.org/pub/scm/linux/kernel/git/firmware/linux-firmware.git
> > 
> > Copy the intel/*.sfi to /lib/firmware/intel/ and cold boot.
> > 
> > It will help to rule out if it is fw issue or not.
> 
> I just tried. I installed the latest linux-firmware-git package that pulled
> latest.
> 
> On cold boot I had `bluetoothctl list` hang after boot. Then after
> restarting the bluetooth service, it showed the device but still refused to
> even do a basic scan.
> 
> `Failed to start discovery: org.bluez.Error.NotReady`
> 
> Then after doing another quick cold boot (stayed off only a few seconds), no
> device was listed at all. =\

Same thing here, just tested with the latest 5.15 that supposedly should
contains the aforementioned fix above:

With the current firmware in linux-firmware, the issue is still the same after
a reboot. With the latest firmware (just downloaded ibt-0041-0041.ddc and sfi,
but if the wireless portion is needed, I can add that too) and that made things
even weirder and weirder. After a cold boot, the adapter was working as
standard. Rebooted and the device was disabled by default (my machine is
configured to auto enable the bluetooth at boot), but after disabling and
reenabling the radio from my DE, the bluetooth reconnected to my mouse for the
first time since I've got this adapter under Linux. After another reboot, the
radio completely disappeared (not even detected from my DE). I don't really
know where the problem resides, but I'm happy that someone is trying to see to
the bottom of this.

Marco.

-- 
You may reply to this email to add a comment.

You are receiving this mail because:
You are the assignee for the bug.

^ permalink raw reply	[flat|nested] 13+ messages in thread

* [Bug 213829] Intel AX210 Bluetooth controller doesn't start from warm boot
       [not found] <bug-213829-62941@https.bugzilla.kernel.org/>
                   ` (7 preceding siblings ...)
  2021-11-13  9:19 ` bugzilla-daemon
@ 2021-11-13 17:55 ` bugzilla-daemon
  2021-11-14  8:07 ` bugzilla-daemon
                   ` (3 subsequent siblings)
  12 siblings, 0 replies; 13+ messages in thread
From: bugzilla-daemon @ 2021-11-13 17:55 UTC (permalink / raw)
  To: linux-bluetooth

https://bugzilla.kernel.org/show_bug.cgi?id=213829

--- Comment #27 from Marco (rodomar705@protonmail.com) ---
(In reply to Guillaume Binet from comment #26)
> Alright, talking with Intel directly, this patch seems to fix it for 5.15.2:
> 
> https://patchwork.kernel.org/project/bluetooth/patch/20211013080511.23945-1-
> kiran.k@intel.com/
> 
> I have a bunch of other regressions like GPU hangs with 5.15 but at least I
> see the controller showing up consistently warm reboot after warm reboot.
> 
> Can anyone else confirm it works?

Nope, running 5.15.2 and now bluetooth disappears after a reboot. This hasn't
fixed the problem for me, it just changed behaviour.

I can confirm that the patch is present, I do see the message added for that
patch:

...
[ 2470.756299] Bluetooth: hci0: Timed out waiting for suspend events
[ 2470.756315] Bluetooth: hci0: Suspend timeout bit: 6
[ 2470.756345] Bluetooth: hci0: Suspend notifier action (3) failed: -110
[13556.607173] Bluetooth: hci0: Firmware timestamp 2021.39 buildtype 1 build
31878
[13556.611182] Bluetooth: hci0: No device address configured
[13556.611197] Bluetooth: hci0: Found device firmware: intel/ibt-0041-0041.sfi
[13556.611306] Bluetooth: hci0: Boot Address: 0x100800
[13556.611308] Bluetooth: hci0: Firmware Version: 134-39.21
[13556.611310] Bluetooth: hci0: Firmware already loaded
...

But there is no bluetooth adapter available from both my DE nor from
bluetoothctl info command.

-- 
You may reply to this email to add a comment.

You are receiving this mail because:
You are the assignee for the bug.

^ permalink raw reply	[flat|nested] 13+ messages in thread

* [Bug 213829] Intel AX210 Bluetooth controller doesn't start from warm boot
       [not found] <bug-213829-62941@https.bugzilla.kernel.org/>
                   ` (8 preceding siblings ...)
  2021-11-13 17:55 ` bugzilla-daemon
@ 2021-11-14  8:07 ` bugzilla-daemon
  2021-11-14 14:36 ` bugzilla-daemon
                   ` (2 subsequent siblings)
  12 siblings, 0 replies; 13+ messages in thread
From: bugzilla-daemon @ 2021-11-14  8:07 UTC (permalink / raw)
  To: linux-bluetooth

https://bugzilla.kernel.org/show_bug.cgi?id=213829

Kiran (kiran.k@intel.com) changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
                 CC|                            |kiran.k@intel.com

--- Comment #29 from Kiran (kiran.k@intel.com) ---


(In reply to Marco from comment #27)
> (In reply to Guillaume Binet from comment #26)
> > Alright, talking with Intel directly, this patch seems to fix it for
> 5.15.2:
> > 
> >
> https://patchwork.kernel.org/project/bluetooth/patch/20211013080511.23945-1-
> > kiran.k@intel.com/
> > 
> > I have a bunch of other regressions like GPU hangs with 5.15 but at least I
> > see the controller showing up consistently warm reboot after warm reboot.
> > 
> > Can anyone else confirm it works?
> 
> Nope, running 5.15.2 and now bluetooth disappears after a reboot. This
> hasn't fixed the problem for me, it just changed behaviour.
> 
> I can confirm that the patch is present, I do see the message added for that
> patch:
> ....
> [13556.611182] Bluetooth: hci0: No device address configured
> [13556.611197] Bluetooth: hci0: Found device firmware:
> ...
> 
> But there is no bluetooth adapter available from both my DE nor from
> bluetoothctl info command.

The log "No device address configured" was present even before this patch.
https://patchwork.kernel.org/project/bluetooth/patch/20211013080511.23945-1-kiran.k@intel.com/

Now its getting printed conditionally based on the mode of the controller. Are
your sure that this patch is present in your test? As of now I can see this
patch merged only in maintainer tree but not in 5.15-rc2

Thanks,
Kiran

-- 
You may reply to this email to add a comment.

You are receiving this mail because:
You are the assignee for the bug.

^ permalink raw reply	[flat|nested] 13+ messages in thread

* [Bug 213829] Intel AX210 Bluetooth controller doesn't start from warm boot
       [not found] <bug-213829-62941@https.bugzilla.kernel.org/>
                   ` (9 preceding siblings ...)
  2021-11-14  8:07 ` bugzilla-daemon
@ 2021-11-14 14:36 ` bugzilla-daemon
  2021-11-25 12:19 ` bugzilla-daemon
  2021-11-26 14:49 ` bugzilla-daemon
  12 siblings, 0 replies; 13+ messages in thread
From: bugzilla-daemon @ 2021-11-14 14:36 UTC (permalink / raw)
  To: linux-bluetooth

https://bugzilla.kernel.org/show_bug.cgi?id=213829

--- Comment #30 from Marco (rodomar705@protonmail.com) ---
(In reply to Kiran from comment #29)
> 
> (In reply to Marco from comment #27)
> > (In reply to Guillaume Binet from comment #26)
> > > Alright, talking with Intel directly, this patch seems to fix it for
> > 5.15.2:
> > > 
> > >
> >
> https://patchwork.kernel.org/project/bluetooth/patch/20211013080511.23945-1-
> > > kiran.k@intel.com/
> > > 
> > > I have a bunch of other regressions like GPU hangs with 5.15 but at least
> I
> > > see the controller showing up consistently warm reboot after warm reboot.
> > > 
> > > Can anyone else confirm it works?
> > 
> > Nope, running 5.15.2 and now bluetooth disappears after a reboot. This
> > hasn't fixed the problem for me, it just changed behaviour.
> > 
> > I can confirm that the patch is present, I do see the message added for
> that
> > patch:
> > ....
> > [13556.611182] Bluetooth: hci0: No device address configured
> > [13556.611197] Bluetooth: hci0: Found device firmware:
> > ...
> > 
> > But there is no bluetooth adapter available from both my DE nor from
> > bluetoothctl info command.
> 
> The log "No device address configured" was present even before this patch.
> https://patchwork.kernel.org/project/bluetooth/patch/20211013080511.23945-1-
> kiran.k@intel.com/
> 
> Now its getting printed conditionally based on the mode of the controller.
> Are your sure that this patch is present in your test? As of now I can see
> this patch merged only in maintainer tree but not in 5.15-rc2
> 
> Thanks,
> Kiran

I'm sorry, Kiran, you were 100% right, even the stock kernel hasn't yet
included that patch. After compiling 5.15.2 plus the above mentioned patch, I
can definitively confirm that on my system the issue is completely fixed.
Rebooted 5 times, each time the bluetooth was working correctly. Finally this
bug is fixed, I hope it will be merged soon, at least on the 5.15 series.

Thanks a lot for your work,

Marco.

-- 
You may reply to this email to add a comment.

You are receiving this mail because:
You are the assignee for the bug.

^ permalink raw reply	[flat|nested] 13+ messages in thread

* [Bug 213829] Intel AX210 Bluetooth controller doesn't start from warm boot
       [not found] <bug-213829-62941@https.bugzilla.kernel.org/>
                   ` (10 preceding siblings ...)
  2021-11-14 14:36 ` bugzilla-daemon
@ 2021-11-25 12:19 ` bugzilla-daemon
  2021-11-26 14:49 ` bugzilla-daemon
  12 siblings, 0 replies; 13+ messages in thread
From: bugzilla-daemon @ 2021-11-25 12:19 UTC (permalink / raw)
  To: linux-bluetooth

https://bugzilla.kernel.org/show_bug.cgi?id=213829

Rohan (crodjer@protonmail.com) changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
                 CC|                            |crodjer@protonmail.com

--- Comment #39 from Rohan (crodjer@protonmail.com) ---
I faced a similar issue
(https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=1000403) on Debian unstable,
but only with v5.15.3. When I built v5.15.4 of the kernel, it went away.

> It is fixed in Arch Linux though.
> I'm using 5.15.4.arch1-1, not the zen kernel.
> 
> See
> https://github.com/archlinux/linux/commit/
> 236027c0ae73217898ac8249e44394cc1026dada

Applying this patch on 5.15.3 didn't resolve this for me, but simply moving to
5.15.4 did.

> 
> Let's hope it will soon land in the mainline kernel too.

-- 
You may reply to this email to add a comment.

You are receiving this mail because:
You are the assignee for the bug.

^ permalink raw reply	[flat|nested] 13+ messages in thread

* [Bug 213829] Intel AX210 Bluetooth controller doesn't start from warm boot
       [not found] <bug-213829-62941@https.bugzilla.kernel.org/>
                   ` (11 preceding siblings ...)
  2021-11-25 12:19 ` bugzilla-daemon
@ 2021-11-26 14:49 ` bugzilla-daemon
  12 siblings, 0 replies; 13+ messages in thread
From: bugzilla-daemon @ 2021-11-26 14:49 UTC (permalink / raw)
  To: linux-bluetooth

https://bugzilla.kernel.org/show_bug.cgi?id=213829

Alexander Konotop (alexander.konotop@gmail.com) changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
                 CC|                            |alexander.konotop@gmail.com

--- Comment #40 from Alexander Konotop (alexander.konotop@gmail.com) ---
I confirm that it's working with 5.15.5-arch1-1

-- 
You may reply to this email to add a comment.

You are receiving this mail because:
You are the assignee for the bug.

^ permalink raw reply	[flat|nested] 13+ messages in thread

end of thread, other threads:[~2021-11-26 14:51 UTC | newest]

Thread overview: 13+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
     [not found] <bug-213829-62941@https.bugzilla.kernel.org/>
2021-09-10  4:41 ` [Bug 213829] Intel AX210 Bluetooth controller doesn't start from warm boot bugzilla-daemon
2021-10-17 18:05 ` bugzilla-daemon
2021-11-02 13:57 ` bugzilla-daemon
2021-11-02 20:02 ` bugzilla-daemon
2021-11-11  1:11 ` bugzilla-daemon
2021-11-11  3:12 ` bugzilla-daemon
2021-11-13  3:43 ` bugzilla-daemon
2021-11-13  9:19 ` bugzilla-daemon
2021-11-13 17:55 ` bugzilla-daemon
2021-11-14  8:07 ` bugzilla-daemon
2021-11-14 14:36 ` bugzilla-daemon
2021-11-25 12:19 ` bugzilla-daemon
2021-11-26 14:49 ` bugzilla-daemon

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).